Issue with Twitter
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 12, 2019 - 08:39 BST
Identified
Twitter is currently experiencing API difficulties which may lead to some issues with posting. We have contacted Twitter and hope they will rectify this soon.
Posted 3 months ago. Jul 11, 2019 - 20:19 BST