Issue with Facebook
Incident Report for Echobox
Resolved
Facebook fixed this issue at approximately 3:30am UTC
Posted 7 months ago. Mar 14, 2019 - 09:19 GMT
Investigating
Facebook and Instagram are experiencing a complete outage: https://bit.ly/2HfIuWN. This is also affecting shares made directly.
Posted 7 months ago. Mar 13, 2019 - 16:22 GMT