Shares not going out
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 27, 2019 - 10:44 GMT
Investigating
Shares aren't currently being processed via Echobox. We are investigating this and hope to have sharing back to normal in the next few minutes. We are sorry for the inconvenience.
Posted 8 months ago. Feb 27, 2019 - 10:38 GMT