Scheduled Maintenance
Incident Report for Echobox
Resolved
System maintenance has been completed successfully.
Posted Jan 19, 2020 - 20:21 GMT
Monitoring
We will be carrying out system maintenance between 20:00 and 21:00 (UTC) on Sunday, 19th January. Echobox may be unavailable for brief periods during this time. Schedules should be unaffected. Thank you for your understanding.
Posted Jan 17, 2020 - 13:06 GMT