Investigating Issue
Incident Report for Echobox
Resolved
We're very sorry for the inconvenience experienced by some of our customers. The issue is now resolved.
Posted 9 months ago. Jan 24, 2019 - 11:45 GMT
Investigating
Echobox is experiencing issues and our team are currently investigating. We apologise for any inconvenience caused.
Posted 9 months ago. Jan 24, 2019 - 11:22 GMT