Issue with Facebook
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 21, 2018 - 10:18 GMT
Identified
Facebook is currently experiencing difficulties which may lead to some issues with posting. Facebook are aware of the issue and are working to resolve it quickly - https://ebx.sh/lYqieM.
Posted 11 months ago. Nov 20, 2018 - 12:52 GMT