Scheduled Maintenance
Incident Report for Echobox
Resolved
The maintenance has been complete successfully. Many thanks for your patience.
Posted Oct 27, 2019 - 20:45 GMT
Identified
We will be carrying out system maintenance between 20:00 and 21:00 (UTC) on Sunday, 27th October. Echobox may be unavailable at times during this period. Thank you for your understanding.
Posted Oct 25, 2019 - 16:46 BST