Investigating Issue
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 07, 2019 - 15:36 BST
Investigating
Echobox is experiencing issues with saving changes to scheduled items and our team are currently investigating. A fix is currently being deployed. We apologise for any inconvenience caused.
Posted 4 months ago. Jun 07, 2019 - 15:23 BST