Shares not being automated
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 5 months ago. May 27, 2019 - 19:22 BST
Identified
Echobox is currently unable to automate shares. Please continue to post manually via Echobox in the interim as our team work to rectify this. We apologise for any inconvenience caused.
Posted 5 months ago. May 27, 2019 - 19:05 BST