Instagram Issues
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 07, 2019 - 09:26 BST
Identified
We are currently having issues with posting to Instagram which may result in some shares failing. We're working on a fix for this and hope to have normal service resumed soon. We're sorry for the inconvenience.
Posted 3 months ago. Aug 06, 2019 - 15:13 BST