Issue with Twitter
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 03, 2019 - 08:41 BST
Identified
Twitter is currently experiencing API difficulties which may lead to some issues with posting. We have contacted Twitter and hope they will rectify this soon.
Posted 18 days ago. Oct 02, 2019 - 11:24 BST