Issue with Facebook
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Nov 28, 2019 - 17:23 GMT
Identified
Facebook is currently experiencing API difficulties which may lead to some issues with posting. We have contacted Facebook and hope they will rectify this soon.
Posted Nov 28, 2019 - 14:43 GMT