Investiggating issue

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 17:20 BST

Investigating

Echobox is experiencing some issues with adding articles and populating editions. We are actively investigating this issue now. We apologise for any inconvenience caused.
Posted Jun 04, 2025 - 16:54 BST
This incident affected: Echobox Email.