Echobox is experiencing problems sharing

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 16:09 GMT

Identified

Echobox's "Share Now" functionality is currently not working. We have identified the cause and are working on a fix.
Posted Feb 17, 2026 - 10:18 GMT

Investigating

Echobox is experiencing issues with sharing. This could impact all networks.
Posted Feb 17, 2026 - 00:03 GMT
This incident affected: Echobox Social.