Investigating Issue
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Sep 04, 2020 - 10:56 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2020 - 10:38 BST
Investigating
Echobox is experiencing a login issue and our team are currently investigating. We apologise for any inconvenience caused.
Posted Sep 04, 2020 - 10:07 BST