Failing to share to LinkedIn

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 11:46 GMT

Identified

We have identified an issue with sharing to LinkedIn pages. We are addressing the situation and apologize for any inconvenience caused.
Posted Nov 17, 2025 - 09:29 GMT
This incident affected: Echobox Social.