Issue with logging in to Echobox Email
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 12:30 GMT
Update
Some users are currently experiencing problems logging into Echobox Email. We are investigating and expect to have the situation resolved shortly.
Posted Nov 07, 2024 - 12:15 GMT
Investigating
Some users are currently experiencing problems logging into Echobox Email. We are investigating and expect to have the situation resolved shortly.
Posted Nov 07, 2024 - 12:15 GMT
This incident affected: Login Platform and Echobox Email.