Login and Posting Delays
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 20:53 GMT
Identified
Echobox is currently experiencing slight login and posting delays. We are working on rectifying this as soon as possible. We apologise for any inconvenience caused.
Posted Nov 10, 2020 - 19:49 GMT