Users unable to login

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 10:07 BST

Update

We are continuing to work on a fix for this issue.
Posted Aug 05, 2025 - 09:18 BST

Identified

Echobox users may experience issues logging in. We are working on rectifying this as soon as possible. We apologize for any inconvenience caused.
Posted Aug 05, 2025 - 09:01 BST
This incident affected: Login Platform, Echobox Social, Echobox Email, and Echobox Benchmarks.