An issue has occurred with Twitter
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Apr 08, 2023 - 11:02 BST
Update
Success! We've been working day-and-night developing a new Twitter integration in response to Twitter's current turmoil. We are happy to announce that we've now completed this work. Please follow the steps in this guide https://ebx.sh/twitterreconnect (Echobox login required). You should now be able to post to Twitter as usual. If you encounter any issues, please contact support@echobox.com.
Posted Apr 08, 2023 - 10:58 BST
Update
Success! We've been working day-and-night developing a new Twitter integration in response to Twitter's current turmoil. We are happy to announce that we've now completed this work. Please follow the steps in this guide https://ebx.sh/twitterreconnect (Echobox login required). You should now be able to post to Twitter as usual. If you encounter any issues, we're happy to help support@echobox.com
Posted Apr 08, 2023 - 10:58 BST
Update
We're continuing our hard work on finalizing a new Twitter integration in response to Twitter's turmoil. In the meantime, please follow these steps on https://ebx.sh/twitterreconnect to start the reconnection process (Echobox login required).
Posted Apr 07, 2023 - 22:07 BST
Update
Given Twitter's unexpected disconnection of API access for many companies, Echobox is working hard on a solution for our customers. Please see https://ebx.sh/twitterturmoil to find out more about the steps we kindly ask you to take in order to prepare for the reconnection process. We apologize for the inconvenience Twitter are causing and will keep you updated on further developments.
Posted Apr 06, 2023 - 18:18 BST
Update
Twitter have unexpectedly degraded or disconnected API access of many companies without warning, including Echobox (see https://ebx.sh/twitterturmoil for more information). The Twitter team are unresponsive but we are working on a possible solution and will update within 24 hours. We apologize for the inconvenience Twitter are causing.
Posted Apr 04, 2023 - 14:33 BST
Identified
Twitter is currently experiencing API difficulties which may lead to some issues with pages being disconnected and unable to reconnect. We have contacted Twitter and hope they will rectify this soon.
Posted Apr 04, 2023 - 12:43 BST