Instagram is currently experiencing issues with posting videos

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 19:57 BST

Identified

Instagram is currently experiencing difficulties with their API, which third-parties (like Echobox) integrate with. This may lead to issues posting videos on Instagram.

We have contacted Instagram and hope they resolve their issue soon. We are monitoring the situation and apologize for any inconvenience caused.
Posted Sep 12, 2025 - 12:02 BST
This incident affected: Echobox Social.