Users unable to login
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Apr 25, 2021 - 14:25 BST
Monitoring
We experienced a short intermittent issue with the Echobox service. We apologise for any inconvenience caused. The issue has been resolved.
Posted Apr 25, 2021 - 11:41 BST