Scheduled Maintenance
Incident Report for Echobox
Resolved
Many thanks for your patience while we carried out this platform improvement.
Posted Sep 25, 2022 - 21:57 BST
Monitoring
We will be carrying out system maintenance between 20:00 and 21:00 (UTC) on Sunday, 25th September. Echobox may be unavailable at times during this period. Thank you for your understanding.
Posted Sep 23, 2022 - 13:16 BST