Issue posting to Facebook

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 11:27 BST

Update

We are currently experiencing instability with Facebook page connections and sharing. Our engineers are working on mitigating this as soon as possible. We apologize for any inconvenience caused.

We have contacted Facebook and hope they resolve their issue soon. We are monitoring the situation and apologize for any inconvenience caused.
Posted Aug 14, 2025 - 12:36 BST

Identified

We are currently experiencing instability with Facebook page connections and sharing. Our engineers are working on mitigating this as soon as possible. We apologize for any inconvenience caused.

We have contacted Facebook and hope they resolve their issue soon. We are monitoring the situation and apologize for any inconvenience caused.
Posted Aug 13, 2025 - 16:43 BST
This incident affected: Echobox Social.