Issue with Twitter

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted 3 years ago. Feb 08, 2023 - 23:17 GMT

Identified

Twitter is currently experiencing API difficulties which may lead to some issues with posting. We have contacted Twitter and hope they will rectify this soon.
Posted 3 years ago. Feb 08, 2023 - 22:36 GMT