Users unable to login
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Jul 09, 2021 - 15:23 BST
Monitoring
We have now resolved the issue will continue to monitor the issue.
Posted Jul 09, 2021 - 14:56 BST
Identified
Echobox users may experience issues logging in. We are working on rectifying this as soon as possible. We apologise for any inconvenience caused.
Posted Jul 09, 2021 - 14:23 BST