Issue with Twitter/X

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 00:25 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 16:35 BST

Identified

Twitter is currently experiencing API difficulties which may lead to some issues with posting. We have identified the issue and working to get this resolved.
Posted Jun 02, 2025 - 11:20 BST
This incident affected: Echobox Social.