Scheduled Maintenance
Incident Report for Echobox
Resolved
Thank you for your patience and understanding. Echbox has finished the platform maintenance.
Posted Aug 01, 2022 - 08:50 BST
Identified
We will be carrying out Instagram platform maintenance on Saturday 30th July and Sunday 31st July. Instagram posting may be unavailable at times during this period. Other social networks are not affected. Thank you for your understanding.
Posted Jul 29, 2022 - 17:13 BST