13th December 2024: Echobox will gradually cease offering X/Twitter over the coming days
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 11:02 GMT
Investigating
13th December 2024: Echobox will gradually cease offering X/Twitter over the coming days. This is due to pricing changes introduced by X/Twitter that has made it untenable for us to continue offering X/Twitter. Your Customer Success Manager will reach out soon to guide you through next steps.
Posted Dec 13, 2024 - 10:29 GMT
This incident affected: Echobox Social.