Investigating Issue

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 18:29 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2026 - 18:16 BST

Investigating

Echobox is experiencing issues, and our team is currently investigating. We apologise for any inconvenience caused.
Posted Jul 06, 2026 - 17:41 BST
This incident affected: Login Platform and Echobox Social.