Scheduled Maintenance
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Mar 17, 2024 - 21:00 GMT
Monitoring
We will be carrying out system maintenance between 20:00 and 21:00 (UTC) on Sunday, 17th March. During this period Echobox may be unavailable and you may be logged out. Scheduled posts will remain unaffected. Thank you for your understanding.
Posted Mar 15, 2024 - 13:14 GMT
This incident affected: Login Platform, Echobox Social, and Echobox Email.