Users unable to login
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 18:04 GMT
Update
We are continuing to monitor for any further issues.
Posted Mar 18, 2024 - 18:04 GMT
Update
Any remaining login issues should now be resolved. If you are still experiencing problems logging in please try clearing your browser cache and cookies, or email support@echobox.com. We apologise for any inconvenience caused.
Posted Mar 18, 2024 - 09:02 GMT
Monitoring
Any remaining login issues should now be resolved. If you are still experiencing problems logging in please email support@echobox.com. We apologise for any inconvenience caused.
Posted Mar 18, 2024 - 09:01 GMT
Identified
Some Echobox users may be experiencing issues logging in. We are working on rectifying this as soon as possible. We apologise for any inconvenience caused.
Posted Mar 18, 2024 - 06:52 GMT
This incident affected: Login Platform.