Users unable to login
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 15:57 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2024 - 15:53 GMT
Identified
Echobox users may experience issues logging in to Social. We are working on rectifying this as soon as possible. We apologise for any inconvenience caused.
Posted Jan 12, 2024 - 15:46 GMT
This incident affected: Echobox Social.