Investigating Issue
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 01:42 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 15, 2021 - 01:31 GMT
Investigating
Echobox is experiencing issues in sharing and our team are currently investigating. We apologise for any inconvenience caused.
Posted Dec 15, 2021 - 00:14 GMT