WhatsApp API provider instability

Incident Report for Echobox

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 10:45 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 09:45 BST

Identified

We're currently experiencing instability with WhatsApp which is affecting Echobox's ability to share to WhatsApp Channels. Our team is actively working to resolve this as quickly as possible.
Posted Jul 23, 2025 - 15:55 BST
This incident affected: Echobox Social.