Users unable to login
Incident Report for Echobox
Resolved
This incident has been resolved.
Posted Sep 06, 2022 - 16:33 BST
Identified
The issue has been identified and a fix is being implemented. Although logging in is possible again performance remains degraded.
Posted Sep 06, 2022 - 15:48 BST
Investigating
Echobox users may experience issues logging in. We are working on rectifying this as soon as possible. We apologise for any inconvenience caused.
Posted Sep 06, 2022 - 15:33 BST